kopilkaurokov.ru - сайт для учителей

Создайте Ваш сайт учителя Курсы ПК и ППК Видеоуроки Олимпиады Вебинары для учителей

Урок Электронные таблицы

Нажмите, чтобы узнать подробности

Каирбекова Марфугаш

Эл. почта: marfuga1967@mail. Ru

Телефон:  87023317597

Тема: «Введение формул  в Электронные таблицы. Стандартные функции»

Цели урока:

  1. Познавательная: познакомить учащихся с
  • Порядком введения формул в ячейки ЭТ,
  • Основными видами встроенных функций,
  • Правилами записи аргументов стандартных функций,
    1. Развивающая:
  • учить строить аналогии, выделять главное, ставить и решать проблемы.
    1. Воспитательная:
  • воспитывать аккуратность, внимательность, вежливость и дисциплинированность.

Тип урока: формирование новых знаний, навыков и умений.

Оборудование: Мультимедийная система, учебник.

Ход урока:

  1. Организационный момент
  2. Актуализация опорных знаний:
  • Расскажите о назначении и основных функциях ЭТ,
  • Объясните назначение элементов стандартного окна ЭТ Excel,
  • Расскажите об основных объектах ЭТ, типах данных, способах ввода, редактирования и форматирования данных, порядке ввода формул в ЭТ,
  • Выскажите свое мнение по поводу оформления таблиц в Excel.
  • Что такое абсолютные и относительные адреса ячеек?
  • Как преобразовать адрес из абсолютного в относительный и наоборот?
  • Что такое автозаполнение? Как им пользоваться?
  • Как создать список данных для автозаполнения?
  1. Мотивация учебной деятельности учеников:
  • Использование стандартных функций значительно облегчает проведение вычислений в ЭТ
  1. Объявление темы и ожидаемых учебных результатов.
  • После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ.
  1. Предоставление необходимой теоретической информации

В поставку EXCEL 2003 входит более 300 функций. Используя VBA можно создавать свои функции.

 1.         Формат стандартной функции:

Имя_Функции (Аргумент)

2.          Аргумент функции

 

Аргументом может быть:

1. Пустой аргумент () - СЕГОДНЯ().

2. Константа - КОРЕНЬ(124).

3. Ссылка на ячейку (адрес) - КОРЕНЬ(А4).

4. Диапазон - СУММ(А3:А8).

5. Несколько аргументов -

а) фиксированное число - ОКРУГЛ(123,4565; 2) = 123,46.

б) неопределенное число (до 30) - СРЗНАЧ(А5:В8; D5:E8; F12; 125).

6. Выражения - КОРЕНЬ(A1^2+A2^2).

7. Другие функции - SIN(РАДИАНЫ(В2)).

3.            Ввод функций

Функции могут использоваться самостоятельно и в составе выражений. Порядок ввода функций одинаковый.

1. Выделить ячейку, в которую вставляем функцию

2. Вставка ð Функция или <fx> или <Shift + F3>

3. В поле Категория выбрать нужную категорию.

4. В поле Функция -функцию. ОК

Внизу диалогового окна появиться краткое описание этой функции. Если необходимо узнать подробнее, то вызвать справку (слева внизу).

5. В появившемся диалоговом окне ввести аргументы.

6. После выбора аргументов в нижней части диалогового окна будет виден результат. Если он правильный, то <ОК>.

7. Если аргументом функции должна быть другая функция, то щелкнуть в поле ввода аргумента и выбрать нужную функцию из списка.

4.            Основные функции

Название

Назначение

Действие

1. Математические – 50 штук

1. ЦЕЛОЕ

Определяет целую часть числа

=ЦЕЛОЕ(412,98)             –412

2. СЛЧИС

Определяет случайное число из [0,1)

=ЦЕЛОЕ(6*СЛЧИС()+1) –

опр. случайное число от 1 до 6

3. РИМСКОЕ

Преобразует число римское

=РИМСКОЕ(1998) –MCMXCVIII

4. ОКРУГЛ

Округляет значение до указанного количества десятичных разрядов

=ОКРУГЛ(123,456; 2)    – 123,46

=ОКРУГЛ(123,456; 1)    – 123,50

=ОКРУГЛ(123,456; -2)   – 100,00

5. ПИ

Число p – 14 знаков

6.SIN

Sin угла в радианах

7. КОРЕНЬ

Квадратный корень

Кубический корень – ^1/3

=КОРЕНЬ (А4+В4)

8.СУММ

Вычисляет сумму – до 30 аргументов кнопка <S>

=СУММ(А1:А7; В1:В7; Е7; С12)

2. Статистические – 80 шт.

1. СРЗНАЧ

Определяет среднее значение

=СРЗНАЧ(А1:А12; С1:С12)

2. МИН

Определяет наименьшее знач.

=МИН(А3:С3; А8:С8)

3. МАКС

Определяет наибольшее знач.

=МАКС(А3:С3; А8:С8)

3. Текстовые – 23 шт.

1. ПРОПНАЧ

В словах первую букву делает прописной, а остальные – строчными.

=ПРОПНАЧ(ИВАНОВ И.И.) 

                Иванов И.И.

2. СИМВОЛ

Преобразует ANSI код в символ

=СИМВОЛ(169)                 –©

4. Дата и время – 14 шт.

1. СЕГОДНЯ

Вставляет сегодняшнюю дату

=СЕГОДНЯ()

2. ДЕНЬНЕД

Определяет день недели указанной даты

=ДЕНЬНЕД(Дата; код)

=ДЕНЬНЕД (СЕГОДНЯ();1)

3. ДЕНЬ

Выделяет день месяца из указанной даты

=ДЕНЬ(12.09.2006) – 12

=ДЕНЬ(СЕГОДНЯ())

3. МЕСЯЦ

Выделяет месяц

=МЕСЯЦ(12.09.2002) –9

3. ГОД

Выделяет год

=год(12.05.2006) – 2006





 

Значение второго параметра для функции ДЕНЬНЕД:

Тип

Возвращаемое число

1 или опущен

Число от 1 (воскресенье) до 7 (суббота).

2

Число от 1 (понедельник) до 7 (воскресенье)

3

Число от 0 (понедельник) до 6 (воскресенье)

5.             Пример использования функций ГОД и СЕГОДНЯ

Эти функции позволяют вычислять в таблице такие данные, как возраст человека по дате его рождения или стаж по дате поступления на работу.

Заполним такую таблицу:

А

В

С

ФИО

Дата

рождения

Возраст

1

Иванов И.И.

11.01.1980

28

2

Петров П.П.

20.05.1995

13

3

Сидоров С.С.

05.12.1999

8

В столбцы ФИО и Дата рождения вносим произвольные данные. Для вычисления возраста используется формула:

=(ГОД(СЕГОДНЯ()-B2)-1900)

Эта формула будет вычислять всегда правильное количество полных лет человека, т.к. для вычисления используется функция СЕГОДНЯ, которая в каждый конкретный момент времени использует текущую дату. (Таблица была составлена 25.08.08, при использовании этого примера позже 5.12.08 будут другие данные в столбце С)

Очень важным достоинством ЭТ является то, что при изменении значения в ячейке, которая участвует в формуле, автоматически это формула пересчитывается и в таблице появляется новый результат.

6.            Ошибки в формулах.

Значение

Описание

########

Получилось слишком длинное число – нужно увеличить ширину столбца или изменить формат ячейки

#ДЕЛ/0

Попытка деления на ноль

#ИМЯ?

В формуле используется несуществующее имя

#ЗНАЧ!

Введено арифметическое выражение, содержащее адрес ячейки с текстом

#ССЫЛКА!

Отсутствуют ячейки, адреса которых используются в формуле

#Н/Д

Нет данных для вычислений. Удобно использовать для резервирования данных под ожидаемые данные. Формула, содержащая адрес ячейки со значением #Н/Д, возвращает результат #Н/Д

#число!

Задан неправильный аргумент функции

#пусто!

В формуле используется пересечение диапазонов, не имеющих общих ячеек

  1. Итоги урока

Вы познакомились с основными стандартными функциями для проведения расчетов в таблицах – Excel. Продолжите предложения:

  • В Excel используется более …  стандартных функций
  • Для того, чтобы вставить функцию надо …
  • Аргументом функции может быть …

После ввода функции результат вычисления мы видим в ячейке, а саму формулу Ожидаемые результаты:

После этого урока ученики смогут:

  • Использовать основные стандартные функции ЭТ Excel,  справочную систему ЭТ Excel для поиска подходящих функций.

VII Домашнее задание: Гл. _______, §_______

Просмотр содержимого документа
«Урок Электронные таблицы »


Каирбекова Марфугаш

Эл. почта: marfuga1967@mail. Ru

Телефон: 87023317597


Тема: «Введение формул в Электронные таблицы. Стандартные функции»


Цели урока:

        1. Познавательная: познакомить учащихся с

  • Порядком введения формул в ячейки ЭТ,

  • Основными видами встроенных функций,

  • Правилами записи аргументов стандартных функций,

        1. Развивающая:

  • учить строить аналогии, выделять главное, ставить и решать проблемы.

        1. Воспитательная:

  • воспитывать аккуратность, внимательность, вежливость и дисциплинированность.


Тип урока: формирование новых знаний, навыков и умений.

Оборудование: Мультимедийная система, учебник.

Ход урока:

  1. Организационный момент

  2. Актуализация опорных знаний:

  • Расскажите о назначении и основных функциях ЭТ,

  • Объясните назначение элементов стандартного окна ЭТ Excel,

  • Расскажите об основных объектах ЭТ, типах данных, способах ввода, редактирования и форматирования данных, порядке ввода формул в ЭТ,

  • Выскажите свое мнение по поводу оформления таблиц в Excel.

  • Что такое абсолютные и относительные адреса ячеек?

  • Как преобразовать адрес из абсолютного в относительный и наоборот?

  • Что такое автозаполнение? Как им пользоваться?

  • Как создать список данных для автозаполнения?

  1. Мотивация учебной деятельности учеников:

  • Использование стандартных функций значительно облегчает проведение вычислений в ЭТ

  1. Объявление темы и ожидаемых учебных результатов.

  • После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ.

  1. Предоставление необходимой теоретической информации


В поставку EXCEL 2003 входит более 300 функций. Используя VBA можно создавать свои функции.


1. Формат стандартной функции:


Имя_Функции (Аргумент)


2. Аргумент функции


Аргументом может быть:

1. Пустой аргумент () - СЕГОДНЯ().

2. Константа - КОРЕНЬ(124).

3. Ссылка на ячейку (адрес) - КОРЕНЬ(А4).

4. Диапазон - СУММ(А3:А8).

5. Несколько аргументов -

а) фиксированное число - ОКРУГЛ(123,4565; 2) = 123,46.

б) неопределенное число (до 30) - СРЗНАЧ(А5:В8; D5:E8; F12; 125).

6. Выражения - КОРЕНЬ(A1^2+A2^2).

7. Другие функции - SIN(РАДИАНЫ(В2)).


3. Ввод функций

Функции могут использоваться самостоятельно и в составе выражений. Порядок ввода функций одинаковый.

1. Выделить ячейку, в которую вставляем функцию

2. Вставка Функция или fx или Shift + F3

3. В поле Категория выбрать нужную категорию.

4. В поле Функция -функцию. ОК

Внизу диалогового окна появиться краткое описание этой функции. Если необходимо узнать подробнее, то вызвать справку (слева внизу).

5. В появившемся диалоговом окне ввести аргументы.

6. После выбора аргументов в нижней части диалогового окна будет виден результат. Если он правильный, то .

7. Если аргументом функции должна быть другая функция, то щелкнуть в поле ввода аргумента и выбрать нужную функцию из списка.


4. Основные функции

Название

Назначение

Действие

1. Математические – 50 штук

1. ЦЕЛОЕ

Определяет целую часть числа

=ЦЕЛОЕ(412,98) –412

2. СЛЧИС

Определяет случайное число из [0,1)

=ЦЕЛОЕ(6*СЛЧИС()+1) –

опр. случайное число от 1 до 6

3. РИМСКОЕ

Преобразует число римское

=РИМСКОЕ(1998) –MCMXCVIII

4. ОКРУГЛ

Округляет значение до указанного количества десятичных разрядов

=ОКРУГЛ(123,456; 2) – 123,46

=ОКРУГЛ(123,456; 1) – 123,50

=ОКРУГЛ(123,456; -2) – 100,00

5. ПИ

Число p – 14 знаков


6.SIN

Sin угла в радианах


7. КОРЕНЬ

Квадратный корень

Кубический корень – ^1/3

=КОРЕНЬ (А4+В4)

8.СУММ

Вычисляет сумму – до 30 аргументов кнопка S

=СУММ(А1:А7; В1:В7; Е7; С12)


2. Статистические – 80 шт.

1. СРЗНАЧ

Определяет среднее значение

=СРЗНАЧ(А1:А12; С1:С12)

2. МИН

Определяет наименьшее знач.

=МИН(А3:С3; А8:С8)

3. МАКС

Определяет наибольшее знач.

=МАКС(А3:С3; А8:С8)

3. Текстовые – 23 шт.

1. ПРОПНАЧ

В словах первую букву делает прописной, а остальные – строчными.

=ПРОПНАЧ(ИВАНОВ И.И.)

Иванов И.И.

2. СИМВОЛ

Преобразует ANSI код в символ

=СИМВОЛ(169) –©

4. Дата и время – 14 шт.

1. СЕГОДНЯ

Вставляет сегодняшнюю дату

=СЕГОДНЯ()

2. ДЕНЬНЕД

Определяет день недели указанной даты

=ДЕНЬНЕД(Дата; код)

=ДЕНЬНЕД (СЕГОДНЯ();1)

3. ДЕНЬ

Выделяет день месяца из указанной даты

=ДЕНЬ(12.09.2006) – 12

=ДЕНЬ(СЕГОДНЯ())

3. МЕСЯЦ

Выделяет месяц

=МЕСЯЦ(12.09.2002) –9

3. ГОД

Выделяет год

=год(12.05.2006) – 2006


Значение второго параметра для функции ДЕНЬНЕД:


Тип

Возвращаемое число

1 или опущен

Число от 1 (воскресенье) до 7 (суббота).

2

Число от 1 (понедельник) до 7 (воскресенье)

3

Число от 0 (понедельник) до 6 (воскресенье)



5. Пример использования функций ГОД и СЕГОДНЯ

Эти функции позволяют вычислять в таблице такие данные, как возраст человека по дате его рождения или стаж по дате поступления на работу.

Заполним такую таблицу:



А

В

С


ФИО

Дата

рождения

Возраст

1

Иванов И.И.

11.01.1980

28

2

Петров П.П.

20.05.1995

13

3

Сидоров С.С.

05.12.1999

8


В столбцы ФИО и Дата рождения вносим произвольные данные. Для вычисления возраста используется формула:

=(ГОД(СЕГОДНЯ()-B2)-1900)

Эта формула будет вычислять всегда правильное количество полных лет человека, т.к. для вычисления используется функция СЕГОДНЯ, которая в каждый конкретный момент времени использует текущую дату. (Таблица была составлена 25.08.08, при использовании этого примера позже 5.12.08 будут другие данные в столбце С)

Очень важным достоинством ЭТ является то, что при изменении значения в ячейке, которая участвует в формуле, автоматически это формула пересчитывается и в таблице появляется новый результат.


6. Ошибки в формулах.


Значение

Описание

########

Получилось слишком длинное число – нужно увеличить ширину столбца или изменить формат ячейки

#ДЕЛ/0

Попытка деления на ноль

#ИМЯ?

В формуле используется несуществующее имя

#ЗНАЧ!

Введено арифметическое выражение, содержащее адрес ячейки с текстом

#ССЫЛКА!

Отсутствуют ячейки, адреса которых используются в формуле

#Н/Д

Нет данных для вычислений. Удобно использовать для резервирования данных под ожидаемые данные. Формула, содержащая адрес ячейки со значением #Н/Д, возвращает результат #Н/Д

#число!

Задан неправильный аргумент функции

#пусто!

В формуле используется пересечение диапазонов, не имеющих общих ячеек


  1. Итоги урока

Вы познакомились с основными стандартными функциями для проведения расчетов в таблицах – Excel. Продолжите предложения:

  • В Excel используется более … стандартных функций

  • Для того, чтобы вставить функцию надо …

  • Аргументом функции может быть …

После ввода функции результат вычисления мы видим в ячейке, а саму формулу Ожидаемые результаты:

После этого урока ученики смогут:

  • Использовать основные стандартные функции ЭТ Excel, справочную систему ЭТ Excel для поиска подходящих функций.

VII Домашнее задание: Гл. _______, §_______


Получите в подарок сайт учителя

Предмет: Информатика

Категория: Уроки

Целевая аудитория: 8 класс

Скачать
Урок Электронные таблицы

Автор: Кайырбекова Марфугаш Тусупжановна

Дата: 01.06.2015

Номер свидетельства: 216735

Похожие файлы

object(ArrayObject)#852 (1) {
  ["storage":"ArrayObject":private] => array(6) {
    ["title"] => string(81) "Открытый урок "Электронные таблицы Microsoft EXCEL""
    ["seo_title"] => string(52) "otkrytyi_urok_eliektronnyie_tablitsy_microsoft_excel"
    ["file_id"] => string(6) "408769"
    ["category_seo"] => string(11) "informatika"
    ["subcategory_seo"] => string(5) "uroki"
    ["date"] => string(10) "1492008985"
  }
}
object(ArrayObject)#874 (1) {
  ["storage":"ArrayObject":private] => array(6) {
    ["title"] => string(169) "Урок по информатике в 9 классе по теме "Сортировка и поиск данных в электронных таблицах Excel." "
    ["seo_title"] => string(102) "urok-po-informatikie-v-9-klassie-po-tiemie-sortirovka-i-poisk-dannykh-v-eliektronnykh-tablitsakh-excel"
    ["file_id"] => string(6) "104433"
    ["category_seo"] => string(11) "informatika"
    ["subcategory_seo"] => string(11) "presentacii"
    ["date"] => string(10) "1402694347"
  }
}
object(ArrayObject)#852 (1) {
  ["storage":"ArrayObject":private] => array(6) {
    ["title"] => string(159) "Конспект урока по информатике для 11 класса УКП  "Моделирование в электронных таблицах" "
    ["seo_title"] => string(93) "konspiekt-uroka-po-informatikie-dlia-11-klassa-ukp-modielirovaniie-v-eliektronnykh-tablitsakh"
    ["file_id"] => string(6) "105862"
    ["category_seo"] => string(11) "informatika"
    ["subcategory_seo"] => string(5) "uroki"
    ["date"] => string(10) "1402919145"
  }
}
object(ArrayObject)#874 (1) {
  ["storage":"ArrayObject":private] => array(6) {
    ["title"] => string(98) "Урок  "Адресация ячеек в формулах электронных таблиц" "
    ["seo_title"] => string(61) "urok-adriesatsiia-iachieiek-v-formulakh-eliektronnykh-tablits"
    ["file_id"] => string(6) "143156"
    ["category_seo"] => string(11) "informatika"
    ["subcategory_seo"] => string(5) "uroki"
    ["date"] => string(10) "1418466356"
  }
}
object(ArrayObject)#852 (1) {
  ["storage":"ArrayObject":private] => array(6) {
    ["title"] => string(199) "Открытый урок  по информатике и ИКТ  в 9 Б классе  по теме: «Сортировка и поиск данных  в электронных таблицах» "
    ["seo_title"] => string(113) "otkrytyi-urok-po-informatikie-i-ikt-v-9-b-klassie-po-tiemie-sortirovka-i-poisk-dannykh-v-eliektronnykh-tablitsakh"
    ["file_id"] => string(6) "104409"
    ["category_seo"] => string(11) "informatika"
    ["subcategory_seo"] => string(5) "uroki"
    ["date"] => string(10) "1402689852"
  }
}



ПОЛУЧИТЕ СВИДЕТЕЛЬСТВО МГНОВЕННО

Добавить свою работу

* Свидетельство о публикации выдается БЕСПЛАТНО, СРАЗУ же после добавления Вами Вашей работы на сайт

Удобный поиск материалов для учителей

Ваш личный кабинет
Проверка свидетельства